Leaderboard data currently not up to date.
Incident Report for Hoxhunt
Resolved
Incident resolved and data is now updating correctly (19th of May at 11:15AM UTC+0)
Posted May 19, 2023 - 15:37 EEST
Investigating
Leaderboard data currently not up to date due to an issue with data export flow.

The visible data has been updated on the 17th of May.

We're currently working to fix this.
Posted May 19, 2023 - 10:48 EEST