Hoxhunt performance issue due to Cloudflare Global Network issues

Incident Report for Hoxhunt

Resolved

Cloudflare has informed the issue is resolved.
Cause: "A change made to how Cloudflare's Web Application Firewall parses requests caused Cloudflare's network to be unavailable for several minutes"
Source and more information: https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
We are resolving this incident.
Posted Dec 05, 2025 - 11:52 EET

Monitoring

Cloudflare has implemented a fix.
https://www.cloudflarestatus.com/incidents/l
Our Knowledge Base and Support portal at support.hoxhunt.com is available again. We are monitoring the situation.
Posted Dec 05, 2025 - 11:20 EET

Identified

There is a current issue at Cloudflare Global Network which may result in slow performance at Hoxhunt or pages not loading with a Cloudflare "Internal Server Error" page. This includes our Knowledge Base at support.hoxhunt.com

Source: https://www.cloudflarestatus.com/incidents/lfrm31y6sw9q
Posted Dec 05, 2025 - 11:06 EET
This incident affected: Hoxhunt Platform (Hoxhunt Training, Hoxhunt Admin, Hoxhunt Response, Hoxhunt Insights) and Hoxhunt Report Button (Hoxhunt Outlook add-in, Hoxhunt Google add-on).