Degraded performance on Hoxhunt platforms

Incident Report for Hoxhunt

Resolved

Hoxhunt platform performance has now normalized. Our developers will make optimization changes to avoid similar performance issues from occurring in the future.
Posted Apr 22, 2025 - 11:30 EEST

Investigating

We are investigating performance issues on the Hoxhunt platforms. Degraded performance is identified to have occurred today for the game.hoxhunt.com , admin.hoxhunt.com and response.hoxhunt.com platforms. Some pages on these platforms may load longer than usual at this time.
Posted Apr 22, 2025 - 11:01 EEST
This incident affected: Hoxhunt Platform (Hoxhunt Training, Hoxhunt Admin, Hoxhunt Response).