Leaderboards are experiencing some technical problems and might not load correctly for all organisations
Incident Report for Hoxhunt
Resolved
This incident has been resolved.
Posted Jul 12, 2023 - 13:44 EEST
Investigating
Hoxhunt has identified the issue and we are working on releasing a fix.
Posted Jul 12, 2023 - 10:53 EEST
This incident affected: Hoxhunt Platform (Hoxhunt Training).