User list not loading on User Management page on Admin portal

Incident Report for Hoxhunt

Resolved

This incident is now resolved. User lists are now loading again on the User Management page of Admin portal. If you experience any more issues, please contact support@hoxhunt.com
Posted Jun 02, 2025 - 10:15 EEST

Identified

We have identified an issue with user lists (regardless of filter) not loading on the User Management page on Admin portal. The issue should be resolved within 1 hour from now. We will provide an update when this issue is resolved.
Posted Jun 02, 2025 - 09:52 EEST
This incident affected: Hoxhunt Platform (Hoxhunt Admin).