Slowness across Hoxhunt Products

Incident Report for Hoxhunt

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 15, 2025 - 10:58 EEST

Investigating

We are investigating an issue where Hoxhunt products are performing slower than normal. While the platform is operational occasional time out issues are possible. Our developers are investigating the issue.
Posted Oct 14, 2025 - 12:10 EEST
This incident affects: Hoxhunt Platform (Hoxhunt Training, Hoxhunt Admin, Hoxhunt Response, Hoxhunt Insights, Hoxhunt Sense).