Hoxhunt button on mobile Outlook may not work for some users

Incident Report for Hoxhunt

Resolved

We have now been able to identify, that a policy within the Microsoft Entra ID conditional access is causing the "AADSTS7000024: Inconsistent broker" issues when reporting emails via Outlook Mobile.

There has likely been a change/update within Microsoft that caused a bug within this section. We have been able to replicate this behavior now and found a solution that stops the error from persisting- a change in the Conditional Access policies, and specifically the policy that has the Require approved client app grant.

Please follow these steps to remediate the issue:

1. Identify the conditional access policy that is being applied that causes this error.
2. Add Hoxhunt Report app to the excluded list in the target resources section of the application policy.

Please find screenshots and additional information regarding this on our Knowledge Base article here:

https://support.hoxhunt.com/hc/en-us/articles/19723438472348--2025-04-Solution-for-the-AADSTS7000024-Inconsistent-broker-application-IDs-reporting-issue-on-Outlook-Mobile

If you need any assistance regarding this, please contact Hoxhunt Support at support@hoxhunt.com
Posted Apr 24, 2025 - 10:56 EEST

Investigating

We are currently investigating an issue with Microsoft where Hoxhunt button on mobile Outlook may not work for some users. After clicking Hoxhunt button, users are presented with a log in dialog. After proceeding through the log in process, the following error may occur:

"Sorry, but we're having trouble signing you in.
AADSTS7000024: Inconsistent broker application IDs asserted by incoming credentials."


According to user reports, the issue is not limited to Hoxhunt Outlook add-in.


We will provide updates and possible remediatory steps as they become available.


Best regards
Hoxhunt Support
Posted Apr 14, 2025 - 15:46 EEST
This incident affected: Hoxhunt Report Button (Hoxhunt Outlook add-in).