Benchmarks page on Admin portal does not load for some organizations

Incident Report for Hoxhunt

Resolved

This incident has been resolved.
Root cause: A code change released yesterday caused certain benchmark simulations to fail loading in the admin portal. The issue was resolved in a follow-up release today.
Apologies for the inconvenience caused.
Posted May 07, 2026 - 12:14 EEST

Update

We are continuing to work on a fix for this issue.
Posted May 06, 2026 - 16:45 EEST

Update

We have identified the issue also affects the Active tab of the Benchmarks page for a smaller subset of organizations/cusotmers

Error message that appears on Active and/or Inactive tabs:
Error: Could not fetch benchmarks

Our developers are looking into a fix for the issue.
Benchmark email delivery and Reports on Insights (https://insights.hoxhunt.com/benchmark) are not affected.
Posted May 06, 2026 - 16:14 EEST

Identified

We have identified an issue with the Inactive tab of the Benchmarks page on the Admin portal (https://admin.hoxhunt.com//phishing-training/benchmarks). Our developers are looking into a fix. Actual benchmark email deliveries and reports are not affected. Reports can be viewed at https://insights.hoxhunt.com/benchmark
Posted May 06, 2026 - 16:02 EEST
This incident affected: Hoxhunt Platform (Hoxhunt Training, Hoxhunt Admin).