Hoxhunt Outlook add-in may return persistent errors for some users
Incident Report for Hoxhunt
Resolved
Microsoft has resolved this issue. Please see details below.

Hoxhunt Support

------

Description of the issue by Microsoft:
User impact: Users may have been unable to leverage Outlook add-ins or view Calendar free/busy information.

Final status: We've successfully deployed the aforementioned change within the affected infrastructure and after a period of monitoring confirmed that issue is no longer occurring.

Scope of impact: Impact was specific to users who were serviced through the affected infrastructure.

Root cause: A recent update exposed a code regression that was leading to incorrectly rerouted traffic for Outlook add-ins and calendar free/busy information requests.

Next steps:
We're reviewing our update procedures to better identify similar issues during our development and testing cycles.

------

Full details: https://admin.microsoft.com/Adminportal/Home?#/servicehealth/history/:/alerts/EX744850
Posted Mar 20, 2024 - 15:42 EET
Update
We are continuing to investigate the issue and are waiting for Microsoft's comments.

Meanwhile, multiple users have reported that Hoxhunt button works in Outlook for Web. Please use it as a workaround if possible.

Hoxhunt Support
Posted Mar 19, 2024 - 17:57 EET
Investigating
Hoxhunt Outlook add-in may return persistent errors for some users.

Error types include (but may not be limited to:

NetworkError
The user is no longer connected to the network. Please check your network connection and try again.

InternalServerError
The Exchange server returned an error. Please look at the diagnostics object for more information.
{"ClientRequestId":"{XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX}","ErrorText":"Token retrieval is not supported for this user."}

Both errors may also be displayed in non-English languages.

Both errors are returned by customer Exchange Server when Hoxhunt add-in is trying to fetch identity token for authentication purposes.

Hoxhunt is currently investigating if there is a workaround to the issue until Microsoft has commented on the root cause.

Hoxhunt Support
Posted Mar 19, 2024 - 11:48 EET
This incident affected: Hoxhunt Report Button (Hoxhunt Outlook add-in).