Hoxhunt button is not working
Incident Report for Hoxhunt
Resolved
This incident has been resolved.
Posted Nov 08, 2023 - 14:08 EET
Monitoring
A fix has been released, and Hoxhunt button is working again.
It may take some time for the fix to reach your Hoxhunt button, so please restart/refresh your Outlook client and try again in a few minutes.

Hoxhunt Support
Posted Nov 08, 2023 - 11:46 EET
Investigating
Hoxhunt button in Outlook clients times out and is thus not working properly.
We are currently investigating the issue.

Hoxhunt Support
Posted Nov 08, 2023 - 11:20 EET
This incident affected: Hoxhunt Platform (Hoxhunt Training).