This incident has been resolved. The issue causing some users to experience a "Something went wrong" or "servers busy" error message when attempting to report an email and view Instant Feedback has been fixed and deployed.
We apologize for the inconvenience this may have caused. All affected components are now operating normally.
Thank you for your patience.
Posted May 21, 2026 - 12:17 EEST
Identified
Some users may be experiencing a "Something went wrong" or "servers busy" error message when attempting to report an email and view Instant Feedback.
We have identified the root cause and our developers are working on a fix. We will provide an update once it has been deployed.
We apologize for the inconvenience.
Posted May 20, 2026 - 13:09 EEST
This incident affected: Hoxhunt Report Button (Hoxhunt Outlook add-in, Hoxhunt Google add-on) and Hoxhunt Platform (Hoxhunt Response).