Benchmarks section in Admin Portal not loading for all customers
Incident Report for Hoxhunt
Resolved
This incident has been resolved. If Benchmarks section still doesn't load, wait for a while and refresh the page.

Hoxhunt Support
Posted Jul 24, 2024 - 15:24 EEST
Identified
The issue has been identified and a fix is being prepared.

Hoxhunt Support
Posted Jul 24, 2024 - 13:36 EEST
Investigating
We are investigating an issue where Benchmarks section isn't loading for all customers.

Hoxhunt Support
Posted Jul 24, 2024 - 12:37 EEST
This incident affected: Hoxhunt Platform (Hoxhunt Admin).